Thursday, September 11, 2008

Missing tool icons, EDIT HTML, COMPOSE tabs - what to do

Have you ever been faced with strange situations like missing tool icons to center text, left-justify or right justify text, make a link list, upload photo or video and just see a shorter tool bar like the one below:
short tool bar in compose editor
when previously you can because you had a longer tool bar like the one below:
long tool bar in Blogger post editor
Perhaps even the EDIT HTML and COMPOSE tabs EDIT HTML & COMPOSE tabs are both missing? Or even both tool icon and EDIT HTML/COMPOSE tabs are missing (just happened to me a short while ago when I was preparing a post in Flock social web browser (see screen shot below):

Blogger post editor problem

It need not be just Flock browser. It can be any other web browser.

What did I do then? All I need to do is to open another web browser like Firefox or any other web browser different from the one where you are having problems. I did exactly that and presto, the tool icon plus the EDIT HTML and COMPOSE tabs magically appeared!

The trick in using a different browser has worked for various different strange problems like getting error codes etc. that I have many browsers in my computer.

If you don't want to use a different browser, you can also try clearing cache and cookies and reopen the post editor window by clicking on the CREATE tab again.

Related post: Missing toolbar and unusable post editor (Singtel)

60 comments:

  1. I tried opening in a different browser, and the new browser also was missing the Edit HTML tab - I am trying to post some flash and can't access the edit HTML tab to do it!! I also tried clearing the cache, didn't work...

    ReplyDelete
  2. Hi peter,
    I am using mozilla firefox, but I cannot see the text formatting on my posting, justify, align left or right could not be found. I also tried internet explorer but no success. I also deleted the coockies and cache. The text formating tools have been missing for long time already... Thanks.

    ReplyDelete
  3. Hi Lavern,

    Did you read the part about EDIT HTML mode and COMPOSE mode? You are probably in my favorite mode - EDIT HTML. Click COMPOSE tab and you will get the text formatting icons

    ReplyDelete
  4. Try using Google Chrome. I have never came across this kind of problems.


    TOP COMMENTATORS

    WIDGET

    ReplyDelete
  5. The extended icons only appear in Compose mode, not in HTML mode presumably because if you're editing HTML, you know how to code those things in yourself.

    (I edit in HTML almost exclusively simply because I have so much more control over how the post will look. Being able to change the runaround on photos, for example, is a big help, and creating tables make things line up properly.)

    ReplyDelete
  6. Hi guys -
    I'm having the same issue as lavern. I'm running Firefox (and IE) but neither will allow me to see the options for HTML or Compose. Its almost as if the page never finished loading. I just cleared my cache and cookies, but to no avail.

    I can post on Blogger but only plain text. Since i'm not great at HTML, this is a real problem.

    Any guidance? Thanks.

    ReplyDelete
  7. Hi Nicholas,

    This problem of having no EDTT HTML/COMPOSE mode, no toolbar occurs most frequently for me with Flock I noticed. Maybe you should try other browsers. There are plenty now. The latest is Google Chrome. I like this new browser. I have Many browsers in my computer, IE, FF, Flock, Opera, Safari, Avant and the latest addition, Chrome.

    Other than that, don't know what other tip to offer except perhaps to try other computers and at other time.

    ReplyDelete
  8. Hi peter,
    Yes you are right, I was looking at the edit HTML mode. My problem is now solved after shifting to the compose mode. Wow, once more you did it again! Is there anything that you don't know about blogging? Seems that you knew everything...

    ReplyDelete
  9. Peter,

    HELP!!!!! My question doesn't have to do with the missing EDIT/HTML or COMPOSE tabs, but it does have to do
    with something missing. I am VERY new to blogging (since 9.2.08) and ever since I've started, my Layout page has been missing the "Add Page Element" option. There is the "Add Gadget" option - is that the same thing? I did research on your blog this morning and tried adding additional browsers. So far, I now have Firefox, Opera, and Chrome - but still no "Add Page Element". What am I doing wrong? All I want to is add a "Sidebar".
    Thanks, kristol

    ReplyDelete
  10. i want to redesign my layout at least 3 columns but i can't do it. maybe you can help me with this problem.

    pls take a look at my blogsite. i hope i can hear from you.

    ReplyDelete
  11. Hi Marri,

    I have now started to convert my blogs to 4 column which I feel is better than 3 column as it will allow one to put more stuff above the fold. Would you be interested in 4 column template?

    ReplyDelete
  12. hi peter!

    that would be much better.
    can you teach me how.
    i'm new in blogging and i really want my site to be substantial in content.

    thanks in advance.
    have a nice day!

    ReplyDelete
  13. Faucheux Family

    Blogger changed the name from Page Element to Gadget. They are the same thing.

    ReplyDelete
  14. My missing Edit HTML and Compose tabs is just killing me! I've cleared caches, deleted temporary files, installed a whole slew of different browsers, and NOTHING has worked. I can't get my tabs back.

    BUT--one weird thing about this bug is that I can log in to blogger using a different account and get the tabs back. Same computer, same everything, but different blogger account. There HAS to be a way to fix this without deleting my account! (fingers crossed)

    ReplyDelete
  15. Go under Settings (Basic Tab), scroll down to Global Settings, and choose YES for "Show Compose Mode for all your Blogs".
    Worked for me.

    ReplyDelete
  16. Kim & Joe,

    Thanks for the reminder. You have a valid point. However, this post is addressed more to the case where COMPOSE mode is enabled, but for some reasons stuff that should be there like the EDIT HTML/COMPOSE tabs are MISSING together with tool bars, etc. I have experienced that strange situation myself.

    ReplyDelete
  17. >i'm using opera 2.62 and i have the same problem; until today everything was working just fine, and now, most of the icons are missing;

    >i cleared the cache... i even made a clean install with a diferent version but it's the same;

    >on firefox is working fine, but i don't like it;

    here's a print link

    ReplyDelete
  18. Hi! Just came across your blog. I too have had missing tool icons for editing my posts. I see the edit html code BUT I don't see a tab for "compose" which appears to be what I need to switch too. Any ideas?? I've tried in firefox and safari.

    ReplyDelete
  19. Check your settings. It is at the bottom of Settings > Basic (Global settings). You have to tick [ ] enable COMPOSE mode for all blogs. But I would encourage you to get used to EDIT HTML mode as you will have better control over your posts.

    ReplyDelete
  20. Thank you so much! Worked perfectly and now I have all of my posting tool icons. I've been messing around with this for far too long. So glad I found your helpful blog. Thank you Thank you Thank you!

    ReplyDelete
  21. I cleared cache etc, but it didn't work. I then fixed my drive by doing the following (and then blogger was back to normal with all the icons):

    Restart

    While booting, press and hold Command and s.

    It gives a rundown of stats and when it is done, type fsck -fy [enter].

    When the process is complete, restart and all is fixed.

    ReplyDelete
  22. Sorry, my comment is meant for Mac users.

    ReplyDelete
  23. just change in settings/basic
    Show Compose Mode for all your blogs:
    yes

    ReplyDelete
  24. My settings are correct, I've cleared the cache, blogger cookies, changed computer, browsers etc. Nothing works.
    How does blogger justify having such a crap interface???
    I wish I had started my blog elsewhere :(

    ReplyDelete
  25. Hi can i add a link in my post to redirect to another blog or website?

    ReplyDelete
  26. I lost the icons and was going to blame my firewall because it's quite aggressive about referring websites. However, they actually disappeared because of Adblock Plus. For some reason, one of the subscription filter packs included the placeholder file "http://www.blogger.com/img/blank.gif". Once I wrote an exception, the icons reappeared.

    ReplyDelete
  27. Omg thanx SO much! This has been bugging me for quite some time now. :)
    ...wut an ugly smiley face

    ReplyDelete
  28. Hi,

    I am having a similar problem. Would really, really appreciate it if you could help.

    ReplyDelete
  29. Sorry, the comment vanished before I could complete it.

    When I go to a new post window, all i see is Title, Link, composeEditHTML and the Font window. where there used to be all the usual tabs, there is nothing.

    also the box in which i would usually write my post is now at the very bottom of the page and says preview on top. that's it. i dont have anything else on the new post page.

    i ve screen grabbed what i can see. and can email that to you.

    could you please please help?

    am losing my mind!

    ReplyDelete
  30. Apparently there are many others facing the same problem. Now waiting for feedback.

    In the meantime, some questions:

    Since when did you faced this problem?
    Have you tried clearing cache and cookie?
    Have you tried using other browsers?
    Any other information?

    ReplyDelete
  31. OK what is your ISP (Internet Service Provider?

    ReplyDelete
  32. Hi peter, i've been having this problem since last morning. have tried clearing cache, cookies, changing mozilla to safari. then upgraded system to the the latest mozilla version. still nothing. currently i am using mozilla firefox 3.5.1

    ReplyDelete
  33. What is your Internet service provider (ISP)?

    ReplyDelete
  34. Is your Internet Service Provider (ISP) Singtel?

    ReplyDelete
  35. Ummm..yes. It is Singtel.

    ReplyDelete
  36. This comment has been removed by the author.

    ReplyDelete
  37. Refer to Distorted unusable post editor. Do keep us updated on your problem.

    ReplyDelete
  38. I have a iBook, an Apple product. I dont have options under tools if i attempt to follow instructions under http://blogging.nitecruzr.net/2009/07/distorted-unusable-post-editor-toolbar.html

    any ideas?

    ReplyDelete
  39. Are you using a MAC instead of a PC?

    ReplyDelete
  40. yes, an ibook is a mac product.

    ReplyDelete
  41. Thank you!!! Finally got it sorted. You are a star!

    ReplyDelete
  42. Dedicated to Peter, my savior, my hero, my knight in shining armour.

    http://sforshenanigans.blogspot.com/2009/07/hallelufuckingjah.html

    ReplyDelete
  43. i oso got this problem ytdy, while using firefox and IE. But i solved the missing "compose" box by using IE's latest version, IE8, and then click on the "Compatibility View" button which is beside the address bar, and the compose box pops up!

    But still, image cannot be uploaded. I solved this by following the "edit proxy settings" method from this website, cos i'm a singtel user: http://blogging.nitecruzr.net/2009/07/distorted-unusable-post-editor-toolbar.html

    hope it helps~

    ReplyDelete
  44. Just wondering how can the post editor's toolbar disappear? I have not changed any setting or even browser etc. I have tried all the methods mentioned earlier and it still did not work. MY ISP is Singtel. Has it got to do with the service provider?

    It was fine for the last few years (since 2006) until 2 days ago. I hope this problem is rectified soon. I have just started enjoying blogspot and was promoting the use of it...

    ReplyDelete
  45. Lily, please refer to Missing toolbar and unusable post editor. Another Singaporean was referred to proxy.singnet.com.sg and was very happy to have solved his problem, so yours should be easily solved too.

    ReplyDelete
  46. Hi Peter,
    I tried Wesley's suggestion

    Restart

    While booting, press and hold the Command and s.

    It gives a rundown of stats and when it is done, type fsck -fy [enter].

    When the process is complete, restart and all is fixed.

    BUT the icons show with no graphics only question marks. I clicked on the one for uploading image. Don't work, no pop up!

    HELP!

    ReplyDelete
  47. eryka,

    Do you happen to be a Singapore resident with Singtel as your ISP?

    ReplyDelete
  48. Hi!

    I am having the same problem here too. I am a Singnet user. I am using IE.8 and Mozilla Firefox. I have lost my compose mode and don't know how to go about. Can help?

    Thanks.

    ReplyDelete
  49. HELPPPPPPP!
    Okay, I'm not so great with the tech parts of the computer. I am using Firefox 3.0.13 and I don't have any of the icons, EDIT HTML, COMPOSE stuff, and under settings I dont even have the BASIC SETTINGS option.
    I tried opening it in Internet Explorer, but that one didnt work either.
    What now?

    ReplyDelete
  50. HELP!!!!!!!!!!!
    I am using Firefox 3.0.13 and I dont have the font options or the edit html or the compose tab OR even the basic settings options in settings.
    How do I get all those other options in the toolbar of New Post?

    ReplyDelete
  51. Do you happen to be located in Singapore and have Singtel as the ISP? If so please refer to Missing toolbar unusable post editor. Let us know if that helps.

    ReplyDelete
  52. No im not in Singapore and im not using Singtel. Also, i tried logging on to blogger with someone else's account on my computer, and all the missing stuff was there. So I guess its just mine that isn't.

    ReplyDelete
  53. On the distorted page, just press "ctrl + F5". On the compose mode, or on the upload pic pop-up, whichever is not responding.

    It always work for me :) Hope it helps!

    ReplyDelete
  54. Finally my problem has solved with final comment Ctrl+F5 suggesstion :-)

    Thanks Pete for the post

    -Giri

    ReplyDelete
  55. Hey I Solve Your Problems

    Go to Blogger Setting Tab And Set Global settings To yes now see your new post icos

    ReplyDelete

Find help, info, instructions, tips, tricks

Tip: Use search box below or this box, labels in the first right sidebar, archive, ctrl+F for this page or sitemap to find topics